Troubleshooting Pairing Issues

Here is a list of common issues that might occur for Pairing that you may experience.

  1. Your EFTPOS terminal and POS Machine need to be on the same network.
    See the Test terminal and guidesfor instructions on how to configure wifi and ethernet on your EFTPOS terminal.

  2. The VAA installed on your terminal must be the same or higher major version as the SPI Library that you are integrating with.
    For example if you are using the version 2.6.8 of the SPI Library, the VAA version on your EFTPOS terminal should be 2.6x or higher. To check the VAA version select "Enter + 8" on your EFTPOS terminal and have a look at the App Ver field. If the VAA version is lower than 2.6x, MX51 can organise for this to be updated for you.

  3. The POS Id entered must be alphanumeric and 16 characters or less.
    Entering spaces or special characters will cause pairing to fail.

  4. When pairing with auto address resolution a valid apiKey must be used, and the acquirerCode should be set to "wbc".

  5. When pairing with auto address resolution enabled, test mode must be also be enabled.

  6. For browser-based POS Systems, if pairing with a https url auto address resolution must be enabled.

  7. Unable to ping the IP Address of the EFTPOS terminal.
    This can often be caused by a slow network or the IP Address being blocked by a firewall.

  8. There may be another POS paired to the EFTPOS terminal.
    Multi-pairing is only supported for Javascript, .NET, and Spice. To get started, please contact the Integrations team at, [email protected] or the relevant Slack channel.